Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Your study contains coding errors. . .
So I've seen the error message "Your study contains coding errors we cannot automatically detect yet" before and I've managed to figure out what went wrong. However, I am completely puzzled by this one.
The study in question has already been fully previewed, and I've launched it as a session twice over the past couple of weeks. Worked perfectly fine, collected data. No code was changed.
Just went to preview the study today (want to modify some parts) and I am getting the above error message and I don't understand why. None of the code has been changed, and it had been previously working just fine!

Some additional information. . .

I also tried to start a new session on this study (which should work since I ran two sessions already) and got the error message "You can't launch a new session because 'int' object has no attribute 'replace'"
Can you add "" as a collaborator so that we can take a look? Thanks!
I am trying to do that right now, but get an error message "Unexpected error occurred. Please try again."

Some more info. . . .

I am also now finding that other studies that I've launched as sessions and collected data from in the past couple weeks are also giving me the "Your study contains coding errors. . . " message. This is really weird.
Sign out and sign in again? We can't reproduce any of these issues. As far as we can see there are already quite a few participants who have successfully completed studies today.

Does this happen to both of your accounts?
You can also paste the URL of your study here. We can add ourselves as collaborators from the server end.
Logged out and back in -- still cant add you as collaborator, get same error message "Unexpected error occurred. Please try again."

There are other studies on our lab account that will preview fine. Tried a study on my account, previews fine.

It seems as though it's only studies on the lab account that have already launched sessions that are the problem.

For instance, the main study in question was launched on Nov 17 and closed on Nov 20. I then launched the same study again on Nov 22 and that session ended Nov 25. Data was collected from both sessions, everything ran fine, data is fine. No code has been changed since the last session closed, haven't touched anything.
Got it. Can you paste the URL of your study here? We can add ourselves as collaborators from the server end.
Thanks for the timely report, Sten! We've found the bugs. The fix will be applied at 11AM EST. If you try again after 11AM, it should work (your study and adding collaborators).

There was a big update last night that aimed at speeding up FF. This was an unintended side effect. It only affected studies with choice responses that have integer targets. Thanks for helping us catch the issue.
Oh great! I'm glad you found the problem and that I could help.

Forum Jump:

Users browsing this thread: 1 Guest(s)